Zona-Alternativa
Hola Bienvenido.

Se que estas alli... Veo que aun no estas REGISTRADO.

Registrate y Participa junto a nosotros. necesitamos de tu ayuda!

-Te Saluda el Staff de Zona-ALTERNATIVA y sus Moderadores-

Zona-Alternativa


 
ÍndicePortalFAQBuscarMiembrosGrupos de UsuariosRegistrarseConectarse

Comparte | 
 

 Estructuras Selectivas I

Ver el tema anterior Ver el tema siguiente Ir abajo 
AutorMensaje
ankhal
Moderador de ProGramacion
Moderador de ProGramacion
avatar

Masculino
Cantidad de envíos : 13
Edad : 26
Localización : acarigua/la goajira
Fecha de inscripción : 18/06/2008

MensajeTema: Estructuras Selectivas I   Jue Jun 26, 2008 3:51 pm

***->SI TIENES DUDAS PLANTEALO EN UN MENSAJE, SI TE GUSTA EL TUTO DEJA UN MENSAJE, SI NO TE GUSTA EL TUTO DEJA UN MENSAJE, SI HAY UN ERROR EN ALGUN CODIGO DEJA UN MENSAJE, Y SI QUIERES CUALQUIER CODIGO EN PSEUDOLENGUAJE DEJA UN MENSAJE Y TE LO HARE LLEGAR.<-***
Estructuras Selectivas


En programación, una sentencia condicional es una instrucción o grupo de instrucciones que se pueden ejecutar o no en función del valor de una condición.

Los tipos más conocidos de setencias condicionales son el SI..ENTONCES (if..then), el SI..ENTONCES..SI NO (if..then..else) y el SEGÚN (case o switch), aunque también podríamos mencionar al lanzamiento de errores como una alternativa más moderna para evitar el "anidamiento" de sentencias condicionales.

Los sentencias condicionales constituyen, junto con los bucles, los pilares de la programación estructurada, y su uso es una evolución de una sentencia en lenguaje ensamblador que ejecutaba la siguiente línea o no en función del valor de una condición.


Estas estructuras se utilizan para TOMAR DECISIONES (por eso también se llaman estructuras de decisión o alternativas). Lo que se hace es EVALUAR una condición, y, a continuación, en función del resultado, se lleva a cabo una opción u otra.

Alternativas simples:

Son los conocidos "si... entonces". Se usan de la siguiente manera (una vez más, la escritura es más o menos personal, siempre que las intenciones queden claras para todos): yo quiero evaluar una condición, y si se cumple (es decir, si es cierta), entonces realizaré una serie de pasos. Esto lo podemos escribir así:

Código:

 SI condicion entonces
    Hago el paso 1
    ....
    Hago el paso N
 fin SI



Otro ejemplo: " una condicion seria para saber si una persona es mayor de edad se necesita saber la mayoria de edad 18 y compararla con la edad ingresada.
tenemos la variable edad en donde se guardo la edad ingresada por el usuario.

Código:

si edad >= 18 entonces
   imprimir " Usted ya es mayor de edad."
fin si

al cumplirse la condicion "edad>=18" se realiza la operacion, en este caso mostrar el mensaje en pantalla.

***->NOTA IMPORTANTISIMA<-***

CADA SI ENTONCES DEBE TENER SU RESPECTIVO CIERRE (FIN SI), DE LO CONTRARIO DARA ERROR EL PROGRAMA.

Alternativas Dobles:

son los conocidos " si..entonces, sino, si no se cumple la primera condicion seguimos mostrando con la segunda, su estructura es asi.

Código:

   si condicion entonces
      HAGO EL RESPECTIVO PASO
   sino
      hago el otro paso.
   fin si

Ejemplo: " hacer una condicion que verifique si el numero ingresado es par o impar, el numero se guardara en la variable Nnumero"
1-* hay que sacar el resto de la division del numero/2, se hace con el modulo (MOD).
Código:

   resto=(Nnumero MOD 2)

   si resto=0 entonces
      imprimir" el numero ", Nnumero , " Es par."
   sino
      imprimir " El numero ", Nnumero , " Es impar. "
   fin si


Alternativas Dobles:

esta alternativa es un poco mas complicada pues son los mismos si-entonces, sino pero anidados pueden ser infinitas condiciones en forma anidadas su estructura es asi.

Código:


   si condicion entonces
      cuerpo1
   sino
      si condicion2 entonces
         cuerpo2
      sino
         si condicion3 entonces
            cuerpo3
         sino
            si condicion4 entonces
               cuerpo4
            sino
               si condicion5 entonces
                  cuerpo5
               sino
                  ultimo_cuerpo
               fin si
            fin si
         fin si
      fin si
   fin si

un ejemplo de su utilizacion en un programa.
Haz clicl en el espacio en blanco para ver el codigo.
Spoiler:
 
Volver arriba Ir abajo
Ver perfil de usuario http://trucosparatupc.blogspot.com
 
Estructuras Selectivas I
Ver el tema anterior Ver el tema siguiente Volver arriba 
Página 1 de 1.
 Temas similares
-
» Tutorial del dia: Estructuras de datos
» Tutorial sobre modelado en war3 - Creación de Estructura Osea o
» Reglamento y Estructura
» Planos soporte volante
» Terreno de Dota2 para el warcraft

Permisos de este foro:No puedes responder a temas en este foro.
Zona-Alternativa :: Turoriales :: Zona de Tutoriales :: .::Tuto Programacion::. :: Programacion para Novatos-
Cambiar a: