Zona-Alternativa
Hola Bienvenido.

Se que estas alli... Veo que aun no estas REGISTRADO.

Registrate y Participa junto a nosotros. necesitamos de tu ayuda!

-Te Saluda el Staff de Zona-ALTERNATIVA y sus Moderadores-

Zona-Alternativa


 
ÍndicePortalFAQBuscarMiembrosGrupos de UsuariosRegistrarseConectarse

Comparte | 
 

 Estructuras Selectivas II

Ver el tema anterior Ver el tema siguiente Ir abajo 

TE GUSTO ESTE TUTORIAL
te gustó este tutorial(deja comentario)
50%
 50% [ 1 ]
gracias es de mucha ayuda(deja comentario)
50%
 50% [ 1 ]
es bueno(deja comentario)
0%
 0% [ 0 ]
no te gusto(deja comentario)
0%
 0% [ 0 ]
no te sirve para nada(deja comentario di por que)
0%
 0% [ 0 ]
es pesimo(deja comentario di por que)
0%
 0% [ 0 ]
Votos Totales : 2
 

AutorMensaje
ankhal
Moderador de ProGramacion
Moderador de ProGramacion
avatar

Masculino
Cantidad de envíos : 13
Edad : 26
Localización : acarigua/la goajira
Fecha de inscripción : 18/06/2008

MensajeTema: Estructuras Selectivas II   Vie Jun 27, 2008 5:44 pm

***->SI TIENES DUDAS PLANTEALO EN UN MENSAJE, SI TE GUSTA EL TUTO DEJA UN MENSAJE, SI NO TE GUSTA EL TUTO DEJA UN MENSAJE, SI HAY UN ERROR EN ALGUN CODIGO DEJA UN MENSAJE, Y SI QUIERES CUALQUIER CODIGO EN PSEUDOLENGUAJE DEJA UN MENSAJE Y TE LO HARE LLEGAR.<-***

En esta segunda parte estudiarmos los casos los cuales son menos usados, que los si- entonces. los casos se usal igual que el si entonces. aunque su estructura es mas sencilla en pseudolenguaje que en C++. espero que les quede claro con la teoria para que al terminar entremos de lleno a la programacion en C++.

Casos(switch-case)


es una Estructura de control empleada en programación, a la que pretenecen otras estructuras como el si("if"), el si-sino("if else");, así como combinaciones propias de determinados lenguajes de programación.

El caso no es tan popular como el if, pero se utiliza con regularidad dentro de algunos programas.

su estructura es asi:

nota: "utilizaremos la variable entera mes, en caso de que mes = 1 mostrar enero y asi sucesivamente"
Código:

casos para mes
 caso mes=1
  escribir "el mes es Enero"
 caso mes=2
  escribir"el mes es Febrero"
  .
  .
  .
  .
  .
  .
  .
  .
  .
 caso mes=12
  escribir "El mes es Diciembre"
fin casos

ahora veamos un ejemplo de el mismo programa que hicimos en la primera parte del tutorial.
HAZ CLIC SOBRE EL SPOILER PARA VER EL CODIGO

Spoiler:
 

Combinaciones



Casos dentro de si-entonces.


Código:

            si sexo = "m" entonces
               ch = (ch+1)
               casos para categoria
               categoria  = "p"
                  chp = (chp + 1)
                  caso categoria = "t"
                     cht = (cht + 1)
                     caso categoria  "M"
                        chm = (chm+1)
                        fin casos
                     
                  
                  
            sino
               si sexo = "f" entonces
                  cm = (cm +1)
                     casos para categoria
            categoria = "p"
                        cmp = (cmp+1)
                        caso categoria = "t"
                           cmt = (cmt+1)
                           caso categoria = "M"
                              cmm = (cmm+1)
                           fin casos
                     
            fin si

EXPLICACION: este es una comparacion combianada casos dentro de si-entonces, de un programa donde se calcula la cantidad de mujeres y hombre que hubo en un festibal deportivo.

calcula la cantidad de hombres y mujeres.
calcula la cantidad de hombres y mujeres por ada categoria
siendo estas:

    * trompo
    **metras
    ***perinola


donde la ejecucion es asi:

si el sexo = m entonces
cantidad de hombres aumente en 1 s("si estaba en 0 aumento uno y ya es 1)
los casos para cada categoria
caso catergoria = t
aumenta la cantidad de hombres que juegan trompo
caso categoria = m
aumenta la cantidad de hombres que juegan metras
caso categoria = p
aumenta la cantidad de hombres que juegan perinola
sino aqui viene el sexo=f
se hace lo mismo pero con cada veriable dedicada a las feminas.

y eso es todo...

si-entonces anidados dentro de un si-entonces,sino.

Se cumple la mima funsion que el ejemplo anterior por lo tanto no es necesario explicar.

Código:

si sexo = "m" entonces
               ch = (ch+1)
               si categoria  = "p" entonces
                  chp = (chp + 1)
                  si categoria = "t" entonces
                     cht = (cht + 1)
                     si categoria = "M" entonces
                        chm = (chm+1)
                        fin si
                     fin si
                  fin si
                  
            sino
               si sexo = "f" entonces
                  cm = (cm +1)
                     si categoria = "p" entonces
                        cmp = (cmp+1)
                        si categoria = "t" entonces
                           cmt = (cmt+1)
                           si categoria = "M" entonces
                              cmm = (cmm+1)
                              fin si
                           fin si
                        fin si
                     fin si
            fin si

Si-entonces dentro de un caso.

Código:

      casos para sexo
         caso sexo= "m"
            ch = (ch+1)
               si categoria  = "p" entonces
                  chp = (chp + 1)
                  si categoria = "t" entonces
                     cht = (cht + 1)
                     si categoria = "M" entonces
                        chm = (chm+1)
                        fin si
                     fin si
                  fin si
                  
         caso sexo= "f"
            cm = (cm +1)
               si categoria = "p" entonces
                  cmp = (cmp+1)
                  si categoria = "t" entonces
                     cmt = (cmt+1)
                        si categoria = "M" entonces
                           cmm = (cmm+1)
                           fin si
                  fin si
               fin si
                     
      fin casos
TAREATAREATAREA TAREATAREATAREA TAREATAREATAREA TAREATAREATAREA TAREATAREATAREA TAREATAREATAREA TAREATAREATAREA TAREATAREATAREA

1*- Hacer un programa que pida la fecha de nacimiento, dia mes y año calcular su edad y determinar si es mayor o menor de edad, y calcular el tiempo que falta por cumplir la mayoria de edad, si es mayor de edad calcular cuanto tiempo ha pasado desde que cumplio la mayoria de edad.
*** Mensaje a mostrar***
- menor de edad:
" Hola ",nombre," tienes ",edad, " y aun eres menor de edad te falta ",tiempo
- mayor de edad:
" hola ",nombre, " tienes ",edad," eres mayor de edad y tienes ",tiempo," siendo mayor de edad"

2*- Realizar un programa que pida dos positivos numero y calcule la multiplicacion la suma la resta la division y de un total de todos los resultados. si los uno de los numeros no es positivo mandar un mensaje de erro diciendo que el numero ingresado no es valido por ser negativo.

ejemplo 1 y 2
multiplicacion = 1*2 =2
division = 1/2= 0.5
suma = 1+2 = 3
resta = 1-2 = 1
----------
suma total = 6.5

si numero -1 y 2
error el numero -1 no esta permitido por ser negativo ejecute el programa nuevamente e ingrese numeros positivos.

nota: favor subir los codigos a un servidor de descargas, y mostrar en un comentario, la direccion donde esta guardado. guardar el codigo en un archivo de texto.

todo eso para poder ser evaluacios por su maestro maximo de la programacion king , jeje osea yo :risa: . bueno el proximo tuto sera los contadores y acumuladores.
:gracias:
:homero:


Última edición por ankhal el Sáb Jun 28, 2008 1:39 pm, editado 4 veces
Volver arriba Ir abajo
Ver perfil de usuario http://trucosparatupc.blogspot.com
uchiha saito
Administrador 2
Administrador 2
avatar

Masculino
Cantidad de envíos : 143
Edad : 31
Localización : Aldea Oculta Del Valle De Las Balas (Acarigua, Violenzuela)
Pais :
Fecha de inscripción : 26/04/2008

MensajeTema: Re: Estructuras Selectivas II   Vie Jun 27, 2008 11:23 pm

WTF???
no veo el tuto
Pd:estan muy buenos te felicito enpesando a leerlos pero casi no tengo tiempo XD

_________________


Anime-Planet.com - anime | manga | reviews

ホセ
Volver arriba Ir abajo
Ver perfil de usuario
ankhal
Moderador de ProGramacion
Moderador de ProGramacion
avatar

Masculino
Cantidad de envíos : 13
Edad : 26
Localización : acarigua/la goajira
Fecha de inscripción : 18/06/2008

MensajeTema: respuesta   Vie Jun 27, 2008 11:54 pm

esta bien lo que pasa que tube que
irme a hechar un baño pa ir al tecno...

no importa eso se lee con calma yo por lo menos le aprendi y le pase la
materia a el profesor con 20 solamente con ver y oir esto es solamente
logica,(mente), vista y oido...

para los que no desarrollan logica son muy buenos los juegos de agilidad
que se consiguen por hay para aprender a usar el cerebro. jejej.

y por los menos les dejare el tutorial de algoritmica,
hasta arreglos(arrays) para pasar al tuto de C++, por eso le meto
bastante TEORIA a este tutorial para no repetir en el de c++ y
solamente ir con ejemplos ejercicios, comando funciones y un poco de
historia y suficiente tarea darle ganas a la gente a estudiar..



jejej este escroll le falicita a uno pa leer...XD

GRACIASGRACIASGRACIAS
Volver arriba Ir abajo
Ver perfil de usuario http://trucosparatupc.blogspot.com
CheatCirio
Admin-EL JEFE
Admin-EL JEFE
avatar

Masculino
Cantidad de envíos : 553
Edad : 34
Localización : Caminando por Konoha
Pais :
Fecha de inscripción : 09/04/2008

MensajeTema: Re: Estructuras Selectivas II   Lun Jun 30, 2008 12:14 am

C++ c++ C++ c++ C++ esperando ese aporte...

_________________


Arrow MI CATALOGO DE SUBIDAS - Presiona AQUI!
-Sirius-Cirio-
Volver arriba Ir abajo
Ver perfil de usuario http://zona-alternativa.foroactivo.com.es
ankhal
Moderador de ProGramacion
Moderador de ProGramacion
avatar

Masculino
Cantidad de envíos : 13
Edad : 26
Localización : acarigua/la goajira
Fecha de inscripción : 18/06/2008

MensajeTema: Re: Estructuras Selectivas II   Lun Jun 30, 2008 1:00 am

ya pss deja la Cmamadera se sabe que quieres que te de mas mas pero esperate tomalo con calma y pausadito sino te vas a joder todo.xD que tal los ejercicios que mande .. tan faciles.
Volver arriba Ir abajo
Ver perfil de usuario http://trucosparatupc.blogspot.com
Contenido patrocinado




MensajeTema: Re: Estructuras Selectivas II   

Volver arriba Ir abajo
 
Estructuras Selectivas II
Ver el tema anterior Ver el tema siguiente Volver arriba 
Página 1 de 1.
 Temas similares
-
» Tutorial del dia: Estructuras de datos
» Tutorial sobre modelado en war3 - Creación de Estructura Osea o
» Reglamento y Estructura
» Planos soporte volante
» Terreno de Dota2 para el warcraft

Permisos de este foro:No puedes responder a temas en este foro.
Zona-Alternativa :: Turoriales :: Zona de Tutoriales :: .::Tuto Programacion::. :: Programacion para Novatos-
Cambiar a: