Zona-Alternativa
Hola Bienvenido.

Se que estas alli... Veo que aun no estas REGISTRADO.

Registrate y Participa junto a nosotros. necesitamos de tu ayuda!

-Te Saluda el Staff de Zona-ALTERNATIVA y sus Moderadores-

Zona-Alternativa


 
ÍndicePortalFAQBuscarMiembrosGrupos de UsuariosRegistrarseConectarse

Comparte | 
 

 \Arreglos(ARRAYS)/

Ver el tema anterior Ver el tema siguiente Ir abajo 

Q TAL ESTE TUTO
es muy bueno
0%
 0% [ 0 ]
interesante
0%
 0% [ 0 ]
malo
0%
 0% [ 0 ]
malisimo
0%
 0% [ 0 ]
extremadamente malo
0%
 0% [ 0 ]
Votos Totales : 0
 

AutorMensaje
ankhal
Moderador de ProGramacion
Moderador de ProGramacion
avatar

Masculino
Cantidad de envíos : 13
Edad : 26
Localización : acarigua/la goajira
Fecha de inscripción : 18/06/2008

MensajeTema: Arreglos(ARRAYS)/   Mar Ago 19, 2008 10:17 pm

ARREGLO

Un arreglo es un conjunto de variables del mismo tipo que pueden ser referenciadas a través de un mismo nombre. La forma de identificar a un elemento determinado es a través de un índice.

La declaración

declarar variable entera Array(10)
( el numero entre parentesis indica que la variable tendra una capacidad de 10 pociciones empezando desde el 0 hasta el 9, donde en cada posicion se guardara cada valor...).

otras delaraciones son:

declarar variable de cadena Arraycadena(5)

declarar variable flotante Arrayflotante(5)

cuando usamos arreglos estos se inicialisan con un ciclo repetitivo para, de tal forma de que cada posicion tenga un valor inicial que podra ser 0, como lo hago yo XD.

Código:

 para i de 0 hasta 9 hacer
    arreglo(i)=0
 fin para

ahora les dejare un ejemplo de como usar los arreglos

Código:

inicio
 //este es un programa donde pedimos el nombre y edad de 5 personas y luego lo imprimimos.

 declarar variable n=5 // este es el tamaño
 declarar variable entera edad(n) //arreglo
 declarar variable de cadena nombre(n)//arreglo
 declarar variable entera i // indice

 declarar variable entera edadtemp //variable temporal
 declarar variable de cadena nomtemp

// estas son variable que contienen y envian el valor al arreglo, con cada repeticion se borran los valores.

 //inicializacion...
 para i de 0 hasta 4 hacer
  edad(i)=0
  nombre(i)= ' '
 fin para

 para i de 0 hasta 4 hacer
  imprimir "escriba nombre: "
  leer nomtemp
  nombre(i)=nomtemp
  imprimir "escriba su edad: "
  leer edadtemp
  edad(i)=edadtemp
 fin para

 para i de 0 hasta 4 hacer
 imprimir nombre(i), " tiene : ",edad(i), " Años."
 fin para

fin

el arreglo por como ven debe tener tres ciclos repetitivos 1 para inicializar 1 para llenar y otro para mostrar.


FIN DEL TUTORIAL... disculpen la falta de informacion de este tutorial para novatos pero es solamente un abreboca de lo que es la programacion en sí, en el tutorial de C++ pondre por cada post un codigo el cual lo ire desglosando para explicar cada funcionamiento... los espero... xD
Volver arriba Ir abajo
Ver perfil de usuario http://trucosparatupc.blogspot.com
 
\Arreglos(ARRAYS)/
Ver el tema anterior Ver el tema siguiente Volver arriba 
Página 1 de 1.
 Temas similares
-
» Nueva versiones/actualizaciones de Minecraft
» Capítulo 12. 12 de noviembre de 2013
» [Hilo Oficial] F1 2011 de Codemasters (2)
» Pequeños arreglos y ajustes para Viking Conquest

Permisos de este foro:No puedes responder a temas en este foro.
Zona-Alternativa :: Turoriales :: Zona de Tutoriales :: .::Tuto Programacion::. :: Programacion para Novatos-
Cambiar a: